Print Version Email Page Add to Favorites Comments Alert Me Add to My Links
Loading...

Wednesday, October 22, 2008

SharePoint 2007: Image Slide Show Web Part

Introduction
Most of the times, there is a demand for a web part, which will show the images stored in Images Library created in SharePoint site in a Slide show manner.

Code Download

How to use this Web Part?

This solution is customized to show images from Images Library as well from image URL.
After adding this web part to your site, edit the Custom Properties of web part by clicking edit -> Modify Shared Web Part.
  1. To display images from Image Library named Photos and a Google image, type the below text in Image URLs custom property of web part: Photos;http://www.google.com/intl/en_ALL/images/logo.gif
  2. Choose the Image Transition from the drop down.
  3. Type in the Transition Delay in seconds.
Enjoy the Slide Show!

37 comments:

Vijay Singh Chauhan said...

i have added the solution, deployed it on web appl, activated feature but when m modifying this webpart its not giving me Cutome setting option...does it need any other configuration...

Nanddeep Nachan said...

Hello Vijay,
I guess, you shold see the Custom Properties (where you can give the image path) at the end of Web Part Properties.
Let me know if this helps you.

Regards,
Nanddeep

Jonathan said...

I downloaded the zip file, extracted the files, and ran the three stsadm commands (addsolution, deploysolution, and activatefeature). All commands completed successfully.

I reset IIS, but I cannot locate the web part when I modify a page. What did I miss?

Thanks!

Nanddeep Nachan said...

Hello Jonathan,
Have you tried below steps?
1. Go to Site Settings.
2. Click Web Parts under Galleries.
3. In Web Part Gallery, Click New.
4. Select check-box next to ImageSlideShow.
5. Click Populate Gallery button.

Now, you should see ImageSlideShow web part in available web parts.
Let me know, if this helps you.

Regards,
Nanddeep

Jonathan said...

Hi Nanddeep,

Those instructions were perfect! I can now see the webpart when I modify the page. I am, however, running into the same issue as Vijay. There is no custom section for the web part. I only see the Appearance, Layout, and Advanced sections. There are no fields for Image URLs, Image Transition, or Transition Delay.

Any suggestions?

Thanks!

Nanddeep Nachan said...

Hello Jonathan,
It was my fault.
I have re-complied the code and created a deployable WSP again. Now, this should work for you.
Let me know.

Thanks,
Nanddeep

zaffy said...

hai...i have download this webpart but i don't know how to deploy it in sharepoint....can u show me step by step to deploy it..thank you very muchhh....:)

Jonathan said...

Hi Nanddepp,

Sorry for the delay - can I just deploy this webpart over the exising one or should I un-deploy the existing one first?

Jonathan

Nanddeep Nachan said...

Hello Jonathan,
Nice to see your comment.

Yes, we have to un-deploy the previous WSP and deploy the new one.

Or else, Simple way could be that... you can redeploy the WSP using below STSADM command:

stsadm.exe -o upgradesolution -f filename.wsp -name nameofwsp -immediate

Thanks,
Nanddeep

Nanddeep Nachan said...

Hey Jonathan,
If you are going by 2nd option (STSADM). Then probably you also need to execute the below command:

stsadm -o execadmsvcjobs

Thanks,
Nanddeep

Nanddeep Nachan said...

Hello Zappy,
Sorry for replying late.

To install this web-part, execute below commands from commands prompt:
stsadm -o addsolution -filename ImageSlideShow.wsp

stsadm -o deploysolution -name ImageSlideShow.wsp -url [url-of-site] -immediate -allowgacdeployment

stsadm -o activatefeature -filename ImageSlideShow\Feature.xml -url [url-of-site]

1. Go to Site Settings.
2. Click Web Parts under Galleries.
3. In Web Part Gallery, Click New.
4. Select check-box next to ImageSlideShow.
5. Click Populate Gallery button.

Now, you should see ImageSlideShow web part in available web parts.

Hope, this should help you.

Thanks,
Nanddeep

shravan said...

Hi,
It works fine if i give images path with ";". but i want to show all images from image libary.

it's not picking the images from this library.
please help me out

Nanddeep Nachan said...

Hello Shravan,
Is the Image Library inside the same site?

Regards,
Nanddeep.

Sharad said...

Hey Nanddeep I follow your Blog very closing and I have used it for 2 critical things. Drop down Navigation for a team site and also the Image slide show wsp.

I am stuck as the management where i work wants the slide show to pick a random picture rather than in a particular sequence..

please help

Sharad Choudhary
schoud7@uic.edu

Nanddeep Nachan said...

Hello Sharad,
Nice to hear that my blog helped you for couple of tasks.
Just to be clear on your question - Does the requirement says, to pickup a single picture at random (like - Pic of the Day)?

Regards,
Nanddeep

Anonymous said...

Can this web part work in SharePoint 3.0?

Ajith George said...

Nandeep, Cool stuff and you deserve true appreciation.

Anonymous said...

Hi

Great webpart

Hi,
It works fine if i give images path with ";". but i want to show all images from image libary.

it's not picking the images from this library.
please help me out

Regards
Ole Madsen

andal said...

hi..
awesome code..

i have one doubt..

in code :

at one place u used "c_TransitionDelay" but previously there is only "m_TransitionDelay"

can u plz explain tis

Nanddeep Nachan said...

Hello Andal,

The variable c_TransitionDelay is a constant, which by default sets the property Transition delay to 5 seconds.

Where as, the variable m_TransitionDelay is used to set the property Transition delay to what user has specified through custom properties.

Hope, I am clear.

andal said...

thx Nanddeep...

it is working fine for me :)

now i am trying keeping ur material as base... hope i sucseed

andal said...

thx .. i am clear..

Tamilkumar said...

Hi nandeep,

gr8 work first of all.

i deployed ur code using cs file,unable to see image url,i want the new code after compilation.

kumar

rami reddy said...

Hi Nandeep,

Thanks a lot for sharing the image slide show webpart. It helped me a lot.

But in one site, when i click new in webpart gallary, i got the error. So, can i poulate the same webpart in other way.

Please help me.

And also, i need calendar webpart setup.Please send me the calendar webpart setup.

I holpe u will send it to me.


Thanks a lot.....

RamiReddy.

Nanddeep Nachan said...

Hello Rami,
Could you please detail out more on the error you are facing, while adding the WebPart?
Is it related to Image Slide Show webpart?

What help I can offer you in Calendar webpart?

rami reddy said...

Dear Nandeep,

Thanks for reply..

When i click "new" in webpart gallery page for populating the wepart, i am getting the following error.

File Not Found. at System.Signature._GetSignature(SignatureStruct& signature, Void* pCorSig, Int32 cCorSig, IntPtr fieldHandle, IntPtr methodHandle, IntPtr declaringTypeHandle)
at System.Signature..ctor(RuntimeMethodHandle methodHandle, RuntimeTypeHandle declaringTypeHandle)
at System.Reflection.RuntimeMethodInfo.get_Signature()
at System.Reflection.RuntimeMethodInfo.FetchNonReturnParameters()
at System.Reflection.RuntimeMethodInfo.GetParameters()
at Microsoft.SharePoint.WebPartPages.SPWebPartSerializer.GetPersonalizableProperties()
at Microsoft.SharePoint.WebPartPages.SPWebPartManager.GetEffectiveWebPartType(Type webPartType, SerializationTarget serializationTarget, Boolean ignoreSupportsAttributeMarkup)
at Microsoft.SharePoint.WebPartPages.SPWebPartManager.GetEffectiveWebPartType(Type aspWebPartType, SerializationTarget serializationTarget)
at Microsoft.SharePoint.ApplicationPages.NewDwp.Page_PreRender(Object sender, EventArgs e)
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.Web.UI.Control.OnPreRender(EventArgs e)
at Microsoft.SharePoint.WebControls.UnsecuredLayoutsPageBase.OnPreRender(EventArgs e)
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
Troubleshoot issues with Windows SharePoint Services.


Please help me out in this issue.


Also, i need calendar webpart setup for getting calenadar webpart in my site.


Thanks Nandeep...

RamiReddy.

Daan said...

Dear,

I deployed your solution and you've done a geat job!

But I've one minor issue:

How can I make the webpart pic his files from a library instead of entering them seperatly?

many thanks in advance!

PS: same problem as:

Hi

Great webpart

Hi,
It works fine if i give images path with ";". but i want to show all images from image libary.

it's not picking the images from this library.
please help me out

Regards
Ole Madsen

Anonymous said...

Really great part, thank you for this! One problem and I'm a bit stumped here: we went from www1 to www when we went live with our site. Now the webpart still points at www1. I have tried uninstalling and reinstalling the solution but it still points at www1. Any thoughts?

edowning said...

Hi,

First of all I must give you thanks for the image slideshow web part. Thank you very much for your hard work and offering it for free!

I have successfully installed the webpart and added it to a page however I do not know how to add the images from a picture gallery inside the same site. I have tried adding the URL (http://sitename...) of the picture gallery however this does not work. Could you please tell me how to point the slideshow webpart to an internal picture gallery?

Thank you!

Nanddeep Nachan said...

Hello edowning,
You need to mention the name of the Picture library in the WebPart property.
Let me know, how it works.

Regards,
Nanddeep Nachan

Anonymous said...

Great webpart but one thing to note, it does not work in mozilla firefox nor safari...Any thoughts anyone???

Anonymous said...

Hi,

Thanks Alot, you have saved my time alot, i have successfully installed Image Slide show webpart and its working fine.really you have done great Job

Regards,
Subbu

கொங்கு நா.அருண் said...

Hi
many thanks for your post with this web part,
i installed this web part and i dont know how to display my all images from picture library.
i tried to give the full path over there (ex: http://localhost:6767/SampleSite/MySample%20Slideshow/Forms/AllItems.aspx and also http://localhost:6767/SampleSite/MySample%20Slideshow) but does'nt work
could you pls expain me how to solve this

Paul said...

Hi Nanddeep, could you please provide Image Slide Show Web Part for SharePoint 2010? Thanks in advance.

David Henderson said...

This rocks! The only thing I would request is an image size limiter. That is, have a custom height/width that would force the images to fit the specified size.

Anonymous said...

Hi nanddeep,
I have followed the steps to deploy the solution. Now, the Image Slide Show web part is visible under Site features but not under Gallery --> Web parts --> new to populate. What should I do? Please help.
Thanks,
Nisha

Anonymous said...

Here's a nice slider for Sharepoint 2010:

http://webparts.olympus-consulting.com

World Clock